获取 Total Control 软件和脚本的版本

函数功能:

获取 Total Control 软件和脚本(REST API 和 JS API)的版本信息。

适用版本:

Total Control 7.0.0 UP11 及以后版本

请求方式:GET
http://IP:8090/TotalControl/v1/settings?q=versions&token=:token
参数说明:
参数名 类型 必选 描述
IP string Y 访问 Total Control 服务器的 IP 地址
token string Y Total Control TOKEN
q string Y 固定值 "versions"
响应参数:

Total Control 提供的 REST API 响应格式都是 JSON ,返回值由关键字 "software"、"javascript" 和 "rest" 组成。

(一)执行接口成功的返回字段说明

字段 类型 描述
software string 获取 Total Control 软件的版本信息。
javascript string 获取 Total Control 提供的脚本 JS API 的版本信息。
rest string 获取 Total Control 提供的脚本 REST API 的版本信息。


返回示例:

{
     "software": "7.0.0.u1133718",
     "javascript": "2.6.1",
     "rest": "1.1.0"
}

(二)执行接口返回 HTTP 状态码为 200,但是结果有误的返回字段说明

字段 类型 描述
status object 执行接口失败,则返回:null 对象
value string 返回失败的具体信息


返回示例:

{
    "status":null,
    "value": "<Error message>"
}
请求示例:

http://localhost:8090/TotalControl/v1/settings?q=versions&token=270eq7lXQK8bXYsJ
示例:

注意:下列示例是通过本机访问 Total Control 服务器,所以 IP 都是用的 "localhost"。

RingoJS 请求示例:

可以复制下面的代码,在 Total Control 的脚本终端中执行,也可以保存为后缀为 js 的文件, 例如:example.js,在Total Control 执行器中执行。

下面的示例适用于 Total Control 7.0.0 UP11 及以后版本

//导入一些 ringoJS 的包
var {request} = require('ringo/httpclient');
var base64 = require('ringo/base64');
//将用户名密码编码,'sigma:76BF7A2D'是用户名和密码,在Total Control系统设置里面可以看到
var userpass = base64.encode('sigma:76BF7A2D');

//第一步:获取 Total Control 脚本开发所用的开发 token
var gettoken = request({
    method: 'GET',
    url: 'http://localhost:8090/TotalControl/v1/login',
    headers: {'Authorization': userpass}
	});

var ret_token = JSON.parse(gettoken.content).value; 
var token = ret_token.token; 
print("//获取 token 的值为:" + token);

//第二步:执行该 API
var ret = request({
    method: 'GET',
    url: 'http://localhost:8090/TotalControl/v1/settings',
    data: {
	"q": "versions",
	"token": token
	}
	});
print(ret.content);
温馨提示:
获取 Total Control 脚本开发所用的开发 token 请看这里

RingoJS 示例运行结果:

成功,则返回:

//获取 token 的值为:m195zZEgY91PMcbo
{
     "software": "7.0.0.u1133718",
     "javascript": "2.6.1",
     "rest": "1.1.0"
}
易语言请求示例:

温馨提示,关于易语言的更多信息,请看:
如何安装易语言
学写第一个易语言程序
如何使用易语言控制一台设备
如何使用易语言控制多台设备

.版本 2

.程序集 窗口程序集_启动窗口

.子程序 __启动窗口_创建完毕
.局部变量 base64, 文本型
.局部变量 token, 文本型
.局部变量 device, 文本型
.局部变量 j_token, 类_json, , , 用来解析获取 token 的 json
.局部变量 j_ret, 类_json, , , 用来解析 REST API 接口的json
.局部变量 bool, 逻辑型
.局部变量 bool_ret, 逻辑型

base64 = 到文本 (编码_BASE64编码 (到字节集 (“sigma:76BF7A2D”)))
输出调试文本 (“将用户名和密码组装成 sigma:76BF7A2D 进行 base64 编码生成的字符串为: ” + base64)
bool = j_token.解析 (到文本 (网页_访问_对象 (“http://localhost:8090/TotalControl/v1/login”, 0, , , , “Authorization:” + base64, , , , , , , , , )))
.如果 (bool)
    输出调试文本 (“第一步,获取 token,返回值为:” + j_token.取数据文本 ())
    token = j_token.取通用属性 (“['value'].token”)
    输出调试文本 (“获取的 token 值为: ” + token)
    bool_ret = j_ret.解析 (编码_utf8到gb2312 (到文本 (网页_访问_对象 (“http://localhost:8090/TotalControl/v1/settings?q=versions&token=” + token, 0))))
    .如果 (bool_ret)
        输出调试文本 (“第二步,返回值为: ” + j_ret.取数据文本 ())

    .否则
        输出调试文本 (“该 API 执行失败”)
    .如果结束

.否则
    输出调试文本 (“获取 token 失败”)
.如果结束

易语言代码运行结果:

成功,则返回:

* 将用户名和密码组装成 sigma:76BF7A2D 进行 base64 编码生成的字符串为: c2lnbWE6M0QzOTE0OTc=
* 第一步,获取 token,返回值为:{"status":true,"value":{"token":"7pR8I0xP2I6E9uO5"}}
* 获取的 token 值为: 7pR8I0xP2I6E9uO5
* 第二步,返回值为: {"software":"7.0.0.u1133827","javascript":"2.7.0","rest":"1.1.0"}